Page tree
Skip to end of metadata
Go to start of metadata

Key Concepts

  • Importing products from CSV file

  • Running the Impose tool to generate optimal layouts

  • Reviewing Imposition AI results and applying layouts to the job

  • Changing product spacing options

  • Exporting a job report

Required modules

  • Imposition AI

Sample Files

Note: If you are starting with this lesson and are not using the lessons in order, you must first import the correct libraries archive found in the lesson folder. In the preferences panel under ‘Diagnostics’ click the ‘Import Libraries’ button and choose ‘library-lesson-8.phxlib

1. Import Products from CSV Spreadsheet

In previous lessons we created products manually by importing CAD layouts, importing artwork, or creating empty products. These methods work fine with our Imposition AI, but often when adding multiple products to a job it is faster and easier to enter the product information in a spreadsheet or export product information directly from your MIS system and import all products into Phoenix in one step.

For this purpose Phoenix supports the CSV spreadsheet format. All product properties and features can be automated via CSV, including Autosnap, bleed/spacing options, artwork die shapefrom PDF inks/layers and more. For a full list of capabilities, please read the “Importing Products from CSV” section of the User Guide available from the Help menu.

Step 1 – Create new job by clicking on the ‘+’ sign in the upper left portion of the Artboard or by selecting “New Job” from the File menu.

Step 2 Apply B1 Press by dragging the press from the Press panel onto the Artboard.

Step 3Locate the CSV file called 436715.csv in the samples folder and open the file for viewing in a spreadsheet program like Microsoft Excel or in a text editor.

The first column is Name, which defines the name of the product. Next column is the order amounts. The last two columns define the Cut Ink in the artwork to get die shape from and the relative path to the artwork itself.

Note: File paths in CSV files can be either relative paths to the CSV file location such as this example or full paths (e.g. C:\jobs\jobXXX\YYY.pdf).

Step 4 – In Phoenix, go to the File menu and select “Import Products from CSV...”


Alternative: Click on the context menu icon in the upper-left corner of the Products Panel and select “Import Products from CSV...”

Step 5 In the file dialog select 436715.csv and click “Open”

Step 6 The Import Products dialog will appear next. Click “OK” to use the Standard preset since this CSV is using standard column names.

Note: The Import Products dialog allows you to select a CSV import preset or create a new preset for importing spreadsheets with custom column names or with no column headings. Default spacing type can also be changed here for entries in the CSV that do not have spacing type defined.

Step 7 Wait for CSV import to complete and review the list of products. You should have 8 products in the job and product shapes should follow the cut lines from the original PDF artwork files.

2. Run Impose

Now we have all our products and order amounts defined we can run Impose to generate layouts for our current press and sheet.

Step 1 Go to the Window menu and select Imposition AI to open the Imposition AI window. Select ‘Impose’ at the top.

Alternative: Go to the Tools menu and select “Impose...”or click the Impose icon in the ganging toolbar.

This will open the Imposition AI window with ‘Impose’ selected.

Step 2 – Under Profiles select ‘Default’ and under products check ‘Select All’, then click run togenerate results.

Step 3 The best results rise to the top of the list, sorted according to the ‘Sort by’ criteria in thetop right of the window. Wait for Impose to complete and review the results. Note the best layout in the job has a Run Length of 12,500.

Each layout will have a preview image on the left-hand side and various information about the layout on the right-hand side, such as run length (number of sheets needed), cost, waste, and press time. Phoenix also reports the range of product overruns and the complexity of the layout for post-press as the number of repeat “Blocks” or the number of sheet turns required for strip (i.e.guillotine) based layouts.

Step 4 Double click on the top layout in the list of results to apply the layout to the job.

Note: You can apply another layout from the list of results at any time until edits are done to the press, sheet or individual products. At that time the results will become out of date and Impose needs to be run again.

3. Change Product Spacing

We generated a good layout in the previous section. We might be able to make improvements byediting the spacing values. For the two folding carton products, “TLS_40205” and “TLS_40206”,we can allow the top and bottom bleed masks to overlap into adjacent flaps.

By default product spacing in Impose and the other ganging tools uses the current bleed mask inthe product, i.e. “Spacing from Bleed”. You can define a uniform contour spacing by selecting “Uniform Spacing” or define different spacing distances for each side of the die independently by selecting “Spacing Margins”.

Step 1 – Go to Products Panel and select “TLS_40205”

Step 2 – Go to the Properties Panel and change “Spacing Type” from “Spacing from Bleed” to “Margins”

Step 3 – Change “Left Spacing” from “0 mm” to “3 mm” to ensure a 3 mm gap between the left edge of the carton and other products in the layout

Step 4 – Change “Right Spacing” from “0 mm” to “3 mm” to ensure a 3 mm gap between the rightedge of the carton and other products in the layout.

Spacing options should now look like this:

Step 5 – Go back to Products Panel and select “TLS_40206”

Step 6 Repeat Steps 2-4 above to also change this product’s spacing to margins based with 3 mm Left Spacing and Right Spacing.

Step 7 Re-run Impose.

Step 8 When finished, review the top result in the list of results. Notice that the Run Length has been decreased from 12,500 to 10,000. Overruns, cost, waste and time have also been reduced. Double-click on this layout to apply it to job.

4. Export Job Report

Now we have our layout we can generate a job report to share and review across departments or for documentation purposes.

Step 1 Go to the File menu and select “Export Report”

Step 2 In the Export Job Report dialog click on “OK” to export the report with default options

Step 3 In the file dialog enter lesson-16.pdf as the file name and click “Save” to generate thereport

Step 4 Open the generated report to review. You should see a preview of the job layout, ink information, and statistics about the job and each individual product in the job.

Quick Navigation