# Phoenix Release Notes

Tilia Labs is proud to announce tilia Phoenix 8.0! We've put a lot of work into this release and we're excited to share it with you. Check out everything new and improved in the release notes below.

Anyone with an active maintenance agreement can download Phoenix from our Downloads page. Not up to date with maintenance? Renew now!

Review the release notes below to see what's new, and check out the upgrade notes for instructions on how to upgrade from previous versions. You can also find the the full list of Tilia Labs Help Desk tickets that were resolved in this version below.

# Minor Releases

23 May 2022

# What's changed in 8.0.3

# Changed in this version

  • Improved "Choose Artwork" button behavior in double sided jobs to apply artwork to front and back

# Fixed in this version

  • Resolved scenario where Imposition AI may return invalid results if using "Sheets of any size" option in the Imposition AI Profile along with enabling Work and Turn or Work and Tumble
  • Fixed problem where rounded paths could get converted to line segments in output files when including digital cutting tables in Imposition AI Things
  • Fixed issue where cut estimation for digital cutting tables could return an error if a product had multiple dielines with the same tool type
  • Addressed issue where marks could not be added when creating products using the API call POST /jobs/{jobid}/products
  • Addressed issue where backside graphics could not be assigned to a product using the API call POST /jobs/{jobid}/products/{productname}/snap
  • Enabled snapping of uploaded files using the API call POST /jobs/{jobid}/products/{productname}/snap
  • Fixed problem where Cut and Stack mode was incorrectly centering unfilled sheets
  • Resolved issue where product margins were not being applied correctly in Lanes mode
  • Fixed PATCH /projects/{projectid}/products/{productname} API call to prevent scenario where product name could be null
  • Resolved problem with CF2 Import presets not saving properly
  • Fixed misspelling in hotfolder logging information
  • Addressed issue where product bleed wasn't being set with the POST /projects/{projectid}/products/flat API call
  • Fixed problem where files without a dieline were always defaulting to using the Cut tool, regardless of Tool Types settings for default cut tool

8 April 2022

# What's changed in 8.0.2

# Changed in this version

  • Updated UI to use 'Project' terminology where 'Job' terminology was still being used
  • Added restriction so now Guillotine Cutter Things will only work with rectangular components to mimic real world capabilities
  • Cleaned up logging of unnecessary error events in tech report logs
  • Added additional logging information for recording when non-embedded artwork is different at job load
  • Contour bleed now automatically restricts the use of rounded corners to non-rectangular product components
  • Updated the algorithm for detecting rectangles from paths to be more accurate
  • Updated REST API to add endpoint to return all CSV Report Presets
  • Updated Projects API to enable changing product name in PATCH /projects/{projectid}/products/{productname}
  • Changed output for ink type in REST API response and text-based reports to match the Open API specification by capitalizing ink type names. Previously this response was all lowercase, which did not match the Open API specification.

# Fixed in this version

  • Resolved scenario where bound products were not being placed on presses with the "Use die specification from template" option enabled
  • Fixed problem where PDF / JDF export failed when layout contained a 1bit TIFF
  • Resolved issue where the ink order was reset after releasing a group
  • Addressed situation in which the Preferences dialog was not launching
  • Fixed problem where all inks were considered spot inks
  • Fixed a UI issue where editing a step and repeat group deselected the repeat
  • Resolved issue where layouts found using 'Lanes' mode that included two-sided products set the work style to 'Flat Work'
  • Fixed an issue where templates specified in product CSV import were ignored
  • Fixed issue where default things were not getting loaded in Phoenix 8.0 in new installation environments (no existing library)
  • Fixed scenario where error 'Instance ID does not exist in template' appeared on project load
  • Fixed regression where product selection would not be active after adding products to a layout with a press assigned
  • Added 'layout-type' back into layout result entity in the REST API so it's properly displayed in layout response

24 February 2022

# What's changed in 8.0.1

# Fixed in this version

  • Fixed an issue where product die shape wasn't created correctly when Shape Search was set to "Largest"
  • Addressed a problem where Dynamic Marks based on component items (for example, eye marks) weren't appearing until a layout was modified.
  • Fixed problem in product CSV import where default rotation type was always being overridden by "Orthogonal" when not specified by the CSV
  • Resolved scenario where DXF files using line type "LWPOLYLINE" were unexpectedly mitered after being imported to Phoenix

Easily See What's Changed

As you're navigating the version 8 documentation, you may see the following emoji - πŸŽ‰ and πŸ†•. Anywhere you see πŸŽ‰, something on that page has been updated to reflect what's new in 8.0. Anywhere you see πŸ†•, there's an all new feature within 8.0. We've added these to make it clear what has changed!

16 February 2022

# What's New in Phoenix 8.0

We've broken down the new features of Phoenix 8.0 into the following groups:

  1. Highlights
  2. Imposition AI
  3. UI Enhancements
  4. Marks
  5. API Improvements
  6. General Updates
  7. New Keywords
  8. Inks
  9. Scripting

# πŸŽ‰ Highlights

# ☯️ Support for Work and Turn / Work and Tumble!

Phoenix 8.0 adds the ability to create Work and Turn or Work and Tumble layouts, both manually and through Imposition AI

# 🀯 ALL NEW Intelligent Drag & Drop Interface!

Speed up your workflow with a revolutionary drag and drop interface that knows what file you're bringing into Phoenix and exactly what to do with it. Quickly Import a CAD Template and drop in your artwork without skipping a beat!

# 🎨 Separations View!

Check your separations with just a click with the new Separations view. Simply click on any ink in the Inks panel to toggle it on or off!

# πŸ”¬ Automatic Ink Coverage Calculation!

Enable Raster Color Analysis to have Phoenix evaluate your artwork on a pixel by pixel basis, enabling precisely calculated ink coverages and control over your artwork! With auto-computed ink coverage, ink cost estimation is better than ever!

# πŸ“ Expanded Custom Properties!

Phoenix 7.0 brought the ability to add custom properties to Products, and we heard how much you loved it. So we added custom properties to more areas of Phoenix, including at both the layout and project level.

# πŸ“¦ Industry first Corrugator Module!

We're bringing a brand new module to Phoenix to support Corrugators! We've modeled corrugation devices and now have support for advanced roll optimization of top-sheet printing and corrugating devices!

# πŸ“Š Custom CSV Reporting!

Step up your reporting game with our new CSV Reporting feature - customized to deliver project reports exactly to your specification using Dynamic Keywords and just the information that you need. Not a fan of looking at that one random piece of info from the default report? You don't have to! Now you can report on just the good stuff.

⏎ Full CSV Reporting documentation

# Imposition AI


# Work and Turn / Work and Tumble

Full support for work and turn and work and tumble layouts. Work and Turn and Work and Tumble layout options are automatically generated when using Sheetfed Offset presses. If a layout is more cost effective with a Work and Turn or Work and Tumble, Phoenix will intelligently select it!

⏎ Setting Work and Turn / Work and Tumble manually in a layout
⏎ Enabling Work and Turn / Work and Tumble in Layout Options within Imposition AI

# New Corrugator Planning Module

A new module for digital corrugator planning is now available, allowing advanced roll optimization of top-sheet printing and corrugating processes, a first in the industry! Planning is performed by modeling corrugation devices and processes with options to specify number of chop and slit knifes.

# Performance optimizations when applying large plans

Phoenix 8.0 includes dramatic performance improvements when applying plan results in Imposition AI both in the user interface and via automation. These optimizations are especially noticeable in plan results including large numbers of layouts.

# Mixing Printed and Cut-only products

Added the ability to place products without printing inks (cut only products) on the same layouts as products with print inks.

# Gang Flat and Bound Products Together

Imposition AI now can place both flat and bound or folded products on the same layout. By default, Imposition AI profiles now show a Plan Rule that restricts the layout to having only products of the same type. These plan rules are fully customizable, so if you want to gang flat and bound products together, simply remove the rule!

⏎ Imposition AI - Plan Rules

# Add Gaps Based On Product Properties

There is a new option in Imposition AI profiles that allows for specifying a gap between products based on a product property. For instance, you could specify a gap when custom order ID numbers for a product differ to more easily separate different orders in finishing.

⏎ Imposition AI - Strip Options

# New Strip Gutter Rule Added When Product Properties Differ

In Imposition AI profiles, a new Gutter Rule has been added to Strip Options to apply gutters in strip-based layouts when product properties differ, giving more fine-grained control when gutters are added between strips in layouts generated with either Horizontal Cut or Vertical Cut strategies.

⏎ Imposition AI - Strip Options

# Improved Performance of Impose and Optimize

Further tuned the Impose and Optimize tools to make them faster πŸŽπŸ’¨

# More Optimizations in Lane-based Planning

The Lanes planning mode in the Plan tool in Imposition AI has been enhanced to better utilize the full width of the roll in scenarios where multiple product shapes are present.

# Seamless Web Item Spanning in Plan

The Plan tool now has the ability to span items across frames for roll-fed work when using the Lanes planning mode, in addition to the spanning between signature pages capability added in Phoenix 7.0. A new Imposition AI profile option β€œAllow frame spanning" can be set to β€œNone”, β€œItems”, or β€œPages”. When set to β€œItems”, Phoenix will utilize the full frame height of the given roll-fed press with component items placed across frame boundaries when needed.

⏎ Imposition AI - Web Options

# Imposition AI Settings Recalled

Settings made in the Imposition AI panel are now automatically saved and recalled after restarting Phoenix, saving users time when frequently using the same settings. The Imposition AI tool, sorting options, stopping parameters, and priority filtering are all restored at application launch.

# New Spacing From Tool Option

A new spacing type β€œTool” has been added to products to utilize the cutting tool widths defined in the Tool Types library to define the spacing required between product components in the layout.

⏎ Product Properties

# UI Refinement


# Drag & Drop Overlay

Phoenix now has an intelligent overlay that gives quick access to the various functions available when a file is brought into Phoenix.

For instance, dragging a PDF into Phoenix will allow you to create a new product, as it always has, but there are two additional drop zones for running Automatch or assigning artwork simply by dropping the file on those zones. Dragging a CF2 template file will give the options to place the template in the layout, but also give options to Import the die template or place the template with the die import wizard.

These behaviors are fully customizable in the Phoenix Preferences in the new Drag & Drop tab.

⏎ Drag and Drop Overview

# Separations View

In both Layout View and Component View, ink visibility can be turned off and on now in the Inks Panel, providing an accurate view of each ink separation in the view. When any inks are turned off, the current view automatically switches to Output Preview mode for more accurate rendering of the currently visible inks. Internally, caching is performed to provide very responsive experience when toggling inks on and off. Note that current ink visibility is purely a display feature and does not affect the way layouts are exported in any way.

⏎ Inks Panel

# Project-level Layers Visibility and Control

The Layers panel is now active in Project View, showing all layers across every layer in the current project. Each individual layer can be turned on or off in Project View which turns them on and off in all layouts where this layer is present.

# New Menu Options to Show/Hide Items Across All Layouts

In the Object menu, new options have been added to Mark, Artwork, Product, and Group visibility sub-menus to β€œShow All in All Layouts” and β€œHide All in All Layouts”. When selected, all items of the given type are hidden or shown across every layout in the project.

# Snap Using Bleed

In Layout View and Component View, when moving items manually, you can now snap to component item bleeds as well as the bounds of their final cut shape. This widely requested feature will boost productivity for users who are frequently placing items next to each other based on their bleed masks.

# New Hotkeys to Toggle Artwork On and Off

New hotkeys have been added to toggle the visibility of artwork on or off in the current layout (Control/Command-3) or across all layouts in the project (Control/Command-4).

# Interactive Rotation in Artboards

Selected items in Layout View and Component View can now be rotated by simply clicking and dragging any of the corner anchor points of an item. Changes to rotation are displayed while the item is being rotated and the Shift hotkey limits allowed rotation changes to increments of 45 degrees.

# Zund Connection Feedback

A new "Testing connection to [Your Zund Table Name]" message is displayed when initializing Plan. This will make it easier to know when Phoenix is trying to connect to the table, as previously Phoenix would simply display "Initializing."

# Show and Hide Fold Lines

There's now an option in the View menu to show or hide Signature Folds.

# View Menu Simplification

The View menu has been simplified and reorganized to declutter and make the options more logical.

# Imposition AI Profile Management Improvements

Imposition AI profiles are now easier to manage in Phoenix. The profiles have been moved into their own tab in Preferences called β€œImposition AI” which supports deleting multiple profiles via multi-select and adding and editing of profiles directly outside of the Imposition AI panel. In addition, the default Imposition AI profile is now editable and deletable.

⏎ Imposition AI Preferences Pane

# Multi-Select Presets in Preferences

In Preferences β†’ Presets, multiple presets can be selected and deleted at the same time now.

# Portuguese Localization πŸ‡΅πŸ‡Ή

Phoenix is now available in Portuguese! We welcome our colegas to enjoy Phoenix in their native language!

# Marks


# Signature Marks

Signature marks have been added for folded and bound signatures with options delimiting signature bounds, page edges, page centers, bleeds, folds, and fold crosses. Line color, length, offset, and thickness can be customized for each delimiter type.

⏎ Signature Marks

# Collation Marks

A new Collation mark type has been introduced for delineating collation patterns across collated signatures in bookwork. Collation marks are highly configurable with options controlling mark dimensions, color, text numbering position, and font. A location settings allows you to place collation marks in the spine, face, jog, and non-jog folded edges to handle perfect bound, section stitch (Smyth sewn), and saddle stitch binding methods. In addition, text can optionally be placed in user-defined top or bottom margins of the folded edges with full dynamic keyword support.

⏎ Collation Marks

# Mirror Marks

We've added a new feature to mark rules to allow for marks to be mirrored for surface printing and sublimation work.

⏎ Mark Print Settings

# Signature support in Dimension marks

Dimension marks now include options for including folded and bound signature page edges, page centers, and fold lines automatically, providing new detailed dimension reporting that is especially useful for bindery processing.

⏎ Dimension Marks

# Toggle Unit Visibility in Dimension Marks

Dimensions marks have a new toggle option to Show Units to allow you to choose to have units displayed in a dimension mark or just the dimension values.

⏎ Dimension Marks

# Added Padding to <layout.run-number> Keyword

Padding has been added to the existing <layout.run-number> keyword for use cases that require the run number to be a fixed number of digits. For example, <layout.run-number.pad.5> will output 00001, 00002, etc.

# API Improvements


# New API Calls

We've added new API calls to add export presets for ZCC, DXF, and Tiling Reports. Several new product-level operations have been added to the Projects API in the REST API, providing granular access to each level of the product data model. You can now programmatically retrieve and edit individual product parts, bound sections, tiles, signatures, and more. Existing product operations have been marked as deprecated.

⏎ Live Docs

# Open API Documentation Response Codes

The Phoenix REST API’s Open API specification now includes all possible response codes and descriptions of all API operations.

# New Status Messages

Status messages in Phoenix are now accessible in text-based reports and in automation via the REST API, allowing potential issues detected by Phoenix to be handled in automated environments. Status message lists were added to project, layout surface, and product levels and match the status messages reported in the Status panel in the Phoenix user interface.

# General Enhancements


Phoenix now takes advantage of the available memory on the system beyond 4GB which can improve performance, especially when running the Plan tool with several items and running automation with multiple concurrency.

# Product Component Shape and Bleed Path Improvements

In previous versions of Phoenix there are rare cases when portions of product component shape and bleed paths can end up slightly malformed. These issues are most common with very small items and items with sharp contours. In Phoenix 8.0, shape and path offset code has been enhanced to handle these cases, producing expected cutting and bleed offset paths across all shapes and sizes. In addition, non-rectangular bleed offset paths are now rounded at corners.

# DXF Export Improvements

We've made DXF export in Phoenix even better, increasing compatibility with third-party software vendors!

# Roll Length Support For Reports, Properties, Ganging

Detailed roll-related information has been added to Project View, XML and JSON reports, and the REST API. In addition, roll length reporting has been added to Imposition AI results in the user interface and in the REST API.

# Project PHX File Size Greatly Reduced

Phoenix now removes any artwork that isn't needed in a job. Previously Phoenix would hold on to artwork that was used in a job, even if that artwork was later removed. This should cut down on file size dramatically for anyone reusing Phoenix jobs!

# Increased Maximum Memory on Windows

Phoenix 8.0 doubles the max heap size for Phoenix on Windows to take advantage of more memory and make Phoenix even speedier!

# Coating and Foil Estimation

Planning and estimating coatings and foils in 8.0 is greatly improved.

Upgrade Note Regarding Coating and Foiling

Phoenix 8.0 introduced full support for coating and foiling processes to Imposition AI. Products containing one or more inks mapped to Coating or Foiling now require a press device with coating or foiling units respectively in order to be included in the Plan or Optimize tool, while in previous releases these inks were not considered during planning.

To ensure these products are processed correctly in Imposition AI, we strongly recommend modeling your production coating and foiling processes by adding the necessary coating or foiling units to presses or creating presses that perform the coating or foiling if these processes are performed separately from printing.

Alternatively, you can map Coating and Foiling inks to another ink type that is not considered in Imposition AI, such as General or Technical to mimic the behavior in Phoenix 7.0 and earlier releases if you do not wish to model your coating and foiling processes in the Things library.

# New Fonts Page Added In Preferences

A new β€œFonts” tab has been added to Preferences displaying tables of all fonts registered in Phoenix at startup as well as all fonts that could not be registered successfully. Font details include font family, format, style, PostScript font name, and local filesystem path of the loaded font file.

⏎ Inks in Preferences

# MacOS Big Sur and Monterey Support

We've added support for macOS Big Sur 11.4 and Monterey 12.0! 🌊

⏎ System Requirements

# Expanded Custom Properties

Custom properties have been greatly expanded beyond products, and can now be added to projects, layouts, layout surfaces, product parts, product components, and library items. Custom properties can be added from the Properties panel in the user interface or in automation. Once added, these properties are accessible in marks via dynamic keywords, in plan rules, exports, and in scripting!

⏎ Custom Property

# New Keywords


# Page Colors

We've added the keyword <component.colors> which resolves to the printing color names on current component item side. In addition, you can now access all page color property keywords indexed by page and page color indices, such as <part.page.1.color.1.name>!

# Bound Part Signatures

You can access the total signatures across all sections in the bound part with the new keyword <part.bound.signatures>

# Signature Placement Index

The keyword [insert new keyword] allows you to identify the copy count of the signature or flat in the web. This is designed for run-length of 1 jobs, i.e. non-repeating frames.

# New Keywords for new Custom Property Types

<component.custom.foo>
<part.custom.foo>
<project.custom.foo>
<surface.custom.foo>
<layout.custom.foo>

# Inks


# Automatic Ink Coverage Calculation

The new Raster ink mode allows Phoenix to evaluate all of the inks on the product to calculate ink coverage and fixes issue where some inks may not be properly detected, or black ink would show incorrectly. Raster mode can be set in the Color Analysis property for a given product page. By default, the Color Analysis property is set to Fast mode, but this can be changed in the Default Properties section of the Product Preferences if you'd like to automatically run raster analysis on all product artwork!

⏎ Inks

# Remove Inks

Phoenix 8.0 now gives you the ability to remove any ink from the Inks Panel in both the component view and layout view! Simply find an ink in the Inks Panel, right-click it, and choose "Remove" from the dropdown menu.

⏎ Inks

# Scripting


# New Scripting Functionality

With all of the new changes in Phoenix in version 8.0, the Scripting tools have also been updated. You can find a list of all of the new scripting tools, along with ones that have received new options, ones that have changed, and the one that has been deprecated here: Scripting Changes in Phoenix 8.0 (opens new window)

# Access Custom Properties

Scripts can access script asset, mark asset, and product properties. This is a game changer that brings scripting to many more people who may otherwise not be as comfortable with scripting! Scripts can now be driven by custom properties, allowing you to define anything in a script simply by adjusting a property. For example, you could have a script mark where the placement, font, color, and more are adjusted just like you would change a product property.

# Scripting Support In Text-based Reports

New scripting capabilities have been added to XML, JSON, and CSV reports. The user-defined scripts are run directly after the report has been generated, allowing advanced customization of the reports themselves or additional actions such as preview image generation to be performed as part of the report generation process. This feature can be used to help integrate reports into other third-party systems or with external report generation tools.

# Upgrade Notes

This is a feature packed release of Phoenix, and with it comes a some changes as we are always improving Phoenix to continue pushing the envelope in our industry. If you're upgrading from a previous version, please follow the steps below:

  1. Export a copy of your current library. This is incredibly useful to refer back to in case you need to revert to your previous version, and is a good practice regardless in case of computer data loss. It's always good to have an onsite backup and an offsite backup! To export your library, navigate to Phoenix Preferences and choose the Diagnostics tab. From here, select Export Libraries and save the resulting .phxlib file to a safe place (and offsite or to the cloud if you can!).

  2. On PC, you can uninstall the previous version of Phoenix through the Control Panel. On Mac, you can delete the .app bundle from the Applications folder. This will only remove the application and not any of your library or preferences.

  3. Run the .msi installer on PC or open the .dmg disk image on Mac and copy the application to your Applications folder.

Mac Installation Note

Recent versions of MacOS will prevent Phoenix from running if you simply double-click the app from the Applications folder. You will see a warning about Apple not being able to check it for malicious software. To open Phoenix, you need to right-click on the app and choose Open. This will let you bypass MacOS trying to verify the software, and allow Phoenix to run. You only need to do this the first time you're running Phoenix.

If you have any questions about this, please reach out to us by visiting our Help Desk.

# Resolved Issues

This release of Phoenix resolved a number of issues that appeared in previous releases. The list below is a comprehensive list of the Tilia Labs Help Desk (TLHD) tickets resolved in this release. Many of these issues were bugs that appeared in one of our tech preview or alpha builds, so we would especially like to thank those who helped us with our Phoenix prerelease program!

Note

Most of these issues are relatively minor and specific to a particular configuration. If you have any questions about the list, please reach out to our Help Desk (opens new window) and we'd be happy to explain in detail.

TLHD Issue Summary
PDF/X warnings don't appear consistently in PDF export
Phoenix sees Black Ink in Job
Black not shown as an ink present in the job
Request for Separations View
Error when moving dimension marks in Phoenix
Barcode 39 not working correctly
Phoenix placing 1 camera mark in margin
Camera marks oddity
Request to add stock type to xml report
Phoenix recognize Black ink in Product which doesn't include Black object
Request for Work-and-Turn Support
Wrong inks being reported
Work & Turn & Work & Tumble Options
Request for the signature trim marks
Phoenix - Imposition AI seemingly stuck on "Initializing"
View Settings: Add "Show Fold Lines" view menu option to toggle fold lines
Phoenix UI issue with Big Sur
Request to mix print and cut products on same sheet
Coating cost not being applied
macOS Big Sur UI
Request to gang flat and bound products together
Big Sur Support
Request to plan front and back signature on same layout
Gap Rule for when Product Properties differ
Combine Flat and Bound products on same layout
Add Phoenix Roll Length Data
License window not showing multiple concurrencies properly
DXF file from Phoenix is not opened by our system DXF parser
The orientation of the sheet to the plate is not correct
QR code mark box not behaving properly
Addition of padding function for <layout.run-number>
Created ink cannot be saved
Line types in saved job lost when tool type removed before job open
Bleed issues with attached job
PDF/X warnings don't appear consistently in PDF export
One camera mark placed at 0,0 on sheet when it can't fit anywhere
Step and Repeat: Newly saved preset not showing up in preset dropdown
Dimension mark text displays incorrectly while drawing manual marks
Coating costs not being applied
Order of things lists in Project View with die making can be misleading
ZCC output not properly encoding
Layer visibility set improperly on artwork updated while project is closed
API not exporting individual vector separation
Marks - "Apply to project" only applies to current layout
Bleed Cannot be set properly from CSV
Wide format devices not retaining the Tumble option for sheet turn
Bleed not coming in correctly in 7.0
Export Cutting JDF API call not correct
Missing functionality in PDF Die Export
Dimension mark regression
Update tiling reports to use the same units as the project, rather than always using millimeters
Last Updated: 5/19/2022, 3:35:44 PM